Main Toolbar

Main Toolbar

Main tool bar in SimLab Composer is located at the top of the application, it gives the user access to the different Workbenches and their menus in SimLab Composer.

image.png

File Menu
Move Menu 
Create Menu
Geometry Menu
Material Menu
Scene States Menu
VR Effects/Media Menu
Interactions Menu
Training Builder Menu
VR Viewer Menu
VR Evaluation
Help Menu




File Menu

In the File Menu the user can perform file and scene operations, including staring a new scene, save, import, export and other operations. Setting general preferences is also done here. 

image.png


Scene Group

New/New Protected

Clears the current scene, then displays Welcome (new scene dialog), where the user can select to create a 2D ground scene, open a scene, or create an empty one. Images for the last opened scenes are displayed under the Recent Files tab for quick access.

image.png

New Protected option is the same as creating a new scene, except that this scenes can only be saved as sim, zim, or vrpackage. If the user attempts to export it into any of the available formats, the below message will appear. This is done to protect users property 3D models from being used by others.

image-1639757656775.png

Open/Open Recent

Opens Open VR Studio file dialog, where the user can brows to a *.sim or *.zim file to open. The Open Recent on the other hand will show a list of the last few *.sim files that were opened.

Save/Save As

Opens Save VR Studio file dialog, where the user can select the name and location for the created *.sim or*.zim file format

Note: Sim file (*.sim) is the native file format for VR Studio. It stores the scene, but it does not include contents it references in the disk space. For moving files between machines it is better to save the scene as Zipped Sim File (*.zim), which collects all needed resources (Textures, Sounds, Thump nails, and other resources) and saves them in a single file that can be passed between machines as it is contains all what is needed. 

Sim and Zim files are compatible between SimLab VR Studio and SimLab Composer in case you need to open a file for rendering, or using any other feature from SimLab Composer.  Models can be moved in  (*.zim) format and both VR Studio and SimLab Composer should be of the same version.

Increment then Save

This feature -with shortcut Ctrl+Alt+Shift+S- will save new increments for the same (*.sim) file. These increment files can be helpful in undoing a feature in a complicated scene after some time. So the user can go back to the file before the feature was added and continue from there.  

image-1641204531911.png

Pack

In addition to *.zim you can use pack the scene to pack the model and its textures in one zip file. Supported formats to be used for Packing include OBJ, Collada, and FBX. This is used usually to move files to other applications on other machines. 

image-1639757824389.png

Textures Optimization

Opens the corresponding dialog, which gives the user the option to optimize textures used in the scene in one click. 
In VR and specially when using stand alone devices like Quest, Pico, Android or iOS, it is important to make sure you are not to consume large amount of memory for textures on those devices to have a smooth VR experience.

image-1639757915687.png

The dialog can also be accessed from Show in Viewer dialog, under VR Viewer menu.

start-vr-experinece.png

The texture table shows Number of Files, and Total size for each texture type. If you do not need one of there types, you can simply click on the delete button in the same raw.

Texture Optimization options:
Remove Duplicate Maps: Removes any duplicate textures and have the materials use a single shared texture.
Compress Maps: Uses a compression algorithm to reduce the size of the texture while maintaining its resolution.
Maps Maximum Size: Sets a maximum resolution for textures, any textures exceeding that resolution will be resized to the maximum size.
Background/HDR Maximum Size: Similar to the Map Maximum Size tool, but applies to Background and HDR images with different height to width ratio.
Output Directory: Determines where the processed files are going to be placed. This option is important to preserve the original textures, in case you want to use them in their original state.

Texture optimization is part of the full model optimization capabilities in VR Studio, the following tutorial shows Texture optimization in action 

Replace Rules

Replace rules makes it easy to replace geometries in the imported file with new entities. For example you can replace a simple cube geometry named Fire with VR Fire effect. It also supports replacing material types, for example each material that includes plastic in its name can be automatically converted to a plastic material.

This tool is usually used by 3D designers, where they do not need to repeat tasks in VR Studio when moving their models.

image-1639758041734.png

Share Group

Import/Export

Opens the corresponding Import/Export Geometry dialog. The import function enables the user to build scenes of 3D models from different file formats. The export function, on the other hand, enables the user to share the created 3D scenes with others in different file formats.

In the Import Geometry dialog, the user can browse to 3D geometry to import. Clicking Open displays the Import File dialog, where the user can set different options for 3D import. General Settings include Up vector; Z axis is selected by default. The user can choose a different access depending on the design of the imported 3D geometry.
Place in view, places the import geometry in the current view, rather than the center of the scene. Keep dynamic link, when checked keeps 3D geometry linked and automatically updates to any changes in the home CAD application.
Zoom to imported model, imports the object to the center of the scene and zooms the camera to it.

Import Measurement and annotations, will import these elements with the 3D geometry.

The Import File dialog will have more elements depending on the imported file format. The image on the left below, is for 3D PDF file import, while the one on the right is for DWG file import.

image-1639759365409.png

image-1639758470867.png

Export function will open the Export Geometry dialog, and will enable the user to export the 3D model to any of the supported file formats. For a list of supported Import/Export file formats, visit this page.

Export Selection

The user can select specific nodes/objects from the scene to be exported. The objects will be exported to the specified folder with their names in the Objects Tree.

image-1639759160946.png image-1639758915814.png

Export Selection can be used to export a single part from the 3D scene or to create a VR Catalog, from the exported selections *.vrpackage(s). Creating VR Catalogs is a feature in SimLab Composer Ultimate edition. The following video shows export selection in action 

3D PDF

3D Scenes created in SimLab Composer can be exported into custom designed 3D PDF files, using SimLab Template Designer. The exported 3D PDF files can be opened using the free Acrobat reader (version 9.0 or newer), to take advantage of all the features in the generated 3D PDF file. 

Creating quick 3D PDF in SimLab Composer can be done following these steps other more advanced 3D PDF file are shown there as well.

image.png

Tutorial video showing how to export 3D models to 3D PDF and visualize it with others using the free Acrobat Reader.


3D WebGL

 

Features exported to 3D PDF files, as well as to HTML/WebGl files are listed in the table below. 

 

Clouds Group

Share to SimLab Cloud

This function enables users to share their 3D scenes as VR Package on SimLab cloud. When selecting this option the Login dialog will appear, where the user can Sign Up/Sign in.

image-1639759101774.png

Once the user logs in, the Cloud Sharing dialog will appear, allowing the user to share created 3D scenes with full features as VR Package. Full features mean all created animation, scene states, actions and more. By default a user will start with a trial sharing space of 2 GB valid for 3 months.

image-1639759135912.png

image-1639759144762.png

A user can manage uploaded files by clicking the Manage Cloud Files button in the Cloud Sharing dialog, which will open the Sharing Manager dialog. As the sharing period or space are expired, a user can purchase SimLab Sharing keys. To learn more about sharing methods and capabilities please refer to this video tutorial (Share VR Package section ONLY).

image-1639759441691.png

image-1639759455450.png

Settings

Preferences

Common settings for 3D scenes can be adjusted once in the Preferences dialog.

Appearance Tab

In this tab the user can set the preferred appearance options in SimLab VR Studio, including:

Language and font; the user can select the language and the font style to be used in SimLab VR Studio from the supported languages combo box, and available fonts list. Changing the language, and font takes effect next time SimLab VR Studio runs.

Style; the user to change the transparency for the objects Tree, and set appearance for 3D area. The 3D area appearance can be set as color, or background image.

image-1639759710079.png

Show objects quick access toolbar; shows the Quick Access Toolbar for ease of access for its objects functionalities.
Generate material preview images; generates preview images to the scene materials in the Scene Materials dialog.

Import/Export Tab

Import Measurements and Text Annotations; the user can select to import measurement and text annotations created in the design CAD package.
Import Polylines can also be checked, and the width of the imported lines can be specified.
Automatically generate texture coordinates; texture coordinates for the imported geometry will be automatically generated when this option is checked.
Scale down preview images of textures; reduces the size of textures images for improving interactivity.

Import/Export file dialog; is shown by default. So every time the user imports or exports models / scenes the dialogs will appear.
If the user checks the "Do not show again for this file type" option in the dialog, clicking this option again will reset the dialogs to show for all.

image-1639759895567.png

image-1639759902130.png

Advanced Tab

preferencs-vt-studio.png

In the Annotation Settings group; the user can select to let SimLab VR Studio Auto set the size of the annotations, or set its Default Size.
Measurement Units, and its Precision can also be set here.

Camera Settings group; has two options Keep Above Ground; stops the camera rotation at the ground level, and will not go below, and it is applicable to Parallel and Perspective cameras.
Two Sided Lighting; when checked will draw faces twice so it always appear, it may give better visualization, but It is recommended to uncheck this option for large scenes.

Directories Settings group; the user may select to move the User Data directory to a new location; the user should copy the original data to the new location before setting the new User Data folder.
Reset Composer data button; will reset the composer data to its original setting.

Flaying Mode Settings group; it allows the user to adjust flying and rotation speed while navigation inside VR studio, when using the keyboard keys for moving and mouse for looking around

Exit

Will display the Save File dialog for the user to save the current scene before exiting the application.


Move Menu

Includes all Transform/Snap/Pivot Tools necessary for positioning any geometry in a 3D scene.

move-menu.png

Transform

Transform functions are used for placing 3D models.

Select None; will clear selection, shortcut (Esc button)

Transform; displays transform axes on the selected object allowing the user to move, rotate, and scale the object. The transform axis will be aligned with the object orientation as shown in the image below. shortcut (2)