Main Toolbar

Main Toolbar

The main toolbar in SimLab Composer is located at the top of the application giving the user access to the different menus.

image.png

File Menu
Move Menu 
Create Menu
Geometry Menu
Material Menu
Scene States Menu
Render Menu

Backing Menu
360 Image Menu
VR Effects/Media Menu
Interactions Menu
Training Builder Menu
VR Catalog Menu

VR Viewer Menu
VR Evaluation
Help Menu




File Menu

In the File Menu, the user can perform file and scene operations, including starting a new scene, save, import, export, and other operations. Setting general preferences is also done here. 

image.png

Scene

New/New Protected

Clears the current scene, then displays Welcome (new scene dialog), where the user can select to create a 2D ground scene, open a scene, or create an empty one. Images for the last opened scenes are displayed under the Recent Files tab for quick access.

image-1639757598063.png

New Protected option is the same as creating a new scene, except that this scene can only be saved as sim, zim, or vrpackage. If the user attempts to export it into any of the available formats, the below message will appear. This is done to protect users' property 3D models from being used by others.

image-1639757656775.png

Open/Open Recent

Opens Open Composer file dialog, where the user can browse to a *.sim or *.zim file to open. The Open Recent on the other hand will show a list of the last few *.sim files that were opened.

Save/Save As

Opens Save Composer file dialog, where the user can select the name and location for the created *.sim or*.zim file format

Note: Sim file (*.sim) is the native file format for Composer. It stores the scene, but it does not include contents it references in the disk space. For moving files between machines it is better to save the scene as Zipped Sim File (*.zim), which collects all needed resources (Textures, Sounds, Thump nails, and other resources) and saves them in a single file that can be passed between machines as it contains all that is needed. 

Sim and Zim files are compatible with SimLab Composer in case you need to open a file for rendering or use any other feature from SimLab Composer.  Models can be moved in  (*.zim) format and both Composer and SimLab Composer should be of the same version.

Increment then Save

This feature -with shortcut Ctrl+Alt+Shift+S- will save new increments for the same (*.sim) file. These increment files can be helpful in undoing a feature in a complicated scene after some time. So the user can go back to the file before the feature was added and continue from there.  

image-1641204531911.png

Pack

In addition to *.zim you can use pack the scene to pack the model and its textures in one zip file. Supported formats to be used for Packing include OBJ, Collada, and FBX. This is used usually to move files to other applications on other machines. 

image-1639757824389.png

Textures Optimization

Opens the corresponding dialog, which gives the user the option to optimize textures used in the scene in one click. 
In VR and especially when using stand-alone devices like Quest, Pico, Android, or iOS, it is important to make sure you are not consuming a large amount of memory for textures on those devices to have a smooth VR experience.

image-1639757915687.png

The dialog can also be accessed from Show in Viewer dialog, under the VR Viewer menu.

start-vr-experinece.png

The texture table shows the Number of Files and the Total size for each texture type. If you do not need one of these types, you can simply click on the delete button in the same raw.

Texture Optimization options:
Remove Duplicate Maps: Removes any duplicate textures and have the materials use a single shared texture.
Compress Maps: Uses a compression algorithm to reduce the size of the texture while maintaining its resolution.
Maps Maximum Size: Sets a maximum resolution for textures, any textures exceeding that resolution will be resized to the maximum size.
Background/HDR Maximum Size: Similar to the Map Maximum Size tool, but applies to Background and HDR images with different height-to-width ratios.
Output Directory: Determines where the processed files are going to be placed. This option is important to preserve the original textures, in case you want to use them in their original state.

Texture optimization is part of the full model optimization capabilities in SimLab Composer, the following tutorial shows Texture optimization in action 

Replace Rules

Replace rules makes it easy to replace geometries in the imported file with new entities. For example, you can replace a simple cube geometry named Fire with the VR Fire effect. It also supports replacing material types, for example, each material that includes plastic in its name can be automatically converted to a plastic material.

This tool is usually used by 3D designers, where they do not need to repeat tasks in SimLab Composer when moving their models.

image-1639758041734.png

Share

Import / Export

Opens the corresponding Import/Export Geometry dialog. The import function enables the user to build scenes of 3D models from different file formats. The export function, on the other hand, enables the user to share the created 3D scenes with others in different file formats.

In the Import Geometry dialog, the user can browse to 3D geometry to import. Clicking Open displays the Import File dialog, where the user can set different options for 3D import. General Settings include an Up vector; the Z axis is selected by default. The user can choose different access depending on the design of the imported 3D geometry.
Place in view places the imported geometry in the current view, rather than the center of the scene. Keep dynamic link, when checked keeps 3D geometry linked and automatically updates to any changes in the home CAD application.
Zoom to the imported model imports the object to the center of the scene and zooms the camera to it.

Import Measurement and annotations will import these elements with the 3D geometry.

The Import File dialog will have more elements depending on the imported file format. The image on the left below, is for 3D PDF file import, while the one on the right is for DWG file import.

image-1639759365409.png

image-1639758470867.png

The export function will open the Export Geometry dialog and will enable the user to export the 3D model to any of the supported file formats. For a list of supported Import/Export file formats, visit this page.

Export Selection

The user can select specific nodes/objects from the scene to be exported. The objects will be exported to the specified folder with their names in the Objects Tree.

image-1639759160946.png image-1639758915814.png

Export Selection can be used to export a single part from the 3D scene or to create a VR Catalog, from the exported selections *.vrpackage(s). Creating VR Catalogs is a feature in SimLab Composer Ultimate edition. The following video shows the export selection in action 

3D PDF

3D Scenes created in SimLab Composer can be exported into custom-designed 3D PDF files, using SimLab Template Designer. The exported 3D PDF files can be opened using the free Acrobat reader (version 9.0 or newer), to take advantage of all the features in the generated 3D PDF file.

image.png

image.png

Features exported to 3D PDF files, as well as to HTML/WebGL files are listed in the table below.

Exported Features
3D PDF Files
HTML5/WebGL Files
3D models and Geometry
 √  √
Textures
Materials and Colors
 √
Scene States
 √
Visualized Scene Options (Lists)
Animations
 √
SimLab Actions
 √
2D Polylines and Annotations
 √
Cameras
 √
Reflection Maps
 √
Bump Maps
 √
Custom Designed Templates
 √

Before attempting to export to 3D PDF, the user needs to choose 3D PDF Settings and make sure to include 3D Area in the template.

Tutorial video showing how to export 3D models to 3D PDF and visualize it with others using the free Acrobat Reader.

3D WebGL

HTML5 Settings dialog enables the user to control the generated HTML file(s). Before exporting to HTML, the user needs to select a template to use for export and to set other HTML parameters.

The HTML template design is fully supported with an advanced 2D layout, the same as in the 3D PDF template designer. Behavior Actions can be exported into HTML5/Web GL, enabling users to create an interactive 3D experience on the web. Reflection maps, sunlight, and shadows are applied to 3D models and exported to HTML, giving them a more realistic look with smoother camera navigation and better material appearance. 3D scenes can be exported into html5 files, the same way 3D PDF files are exported.

From 3D WebGL under the File menu,  click Settings to open the HTML5 Settings dialog, where the user can select the template to use from the Template tab. The template tab is where the user can browse the folder containing the HTML template(s) to use, and create New templates, Edit, Delete, or Refresh template(s).

Clicking the New button will open the SimLab Designer window. SimLab Designer is a simple application that enables users to design and save their own templates. Page Size under the File menu of the template designer can be used to expand the background image when the Web GL is set to full screen.  For more details about SimLab Designer, select Designer Help from the Settings/Help bar in SimLab Composer.

Document Javascript and 3D Javascript can be added to control both, the HTML document, and the included 3D model.

Java scripts can be applied to designed templates, to make specific actions. Details about Javascript support in WebGL can be found under Help in SimLab Scripting.

image.png

In the 3D tab of the Html5 Settings dialog, the user can control the behavior/properties in the 3D area. Keep Camera Above Ground option, allows architects to prevent viewers of their 3D models from viewing under the buildings, also the user can show/hide the Shadow From Sun, the Reflection, and the Sun Environment.
The user can also select the Navigation Mode in the exported HTML file, spin navigation mode adds a great navigation experience. The user can set the default navigation mode for the exported 3D WebGL file and can choose to change this default mode from inside the exported 3D WebGL.
For WebGL with animations added to them, the behavior of the animation can be controlled in this tab. Frames Per Second controls the speed of playing animation, where 15 FPS is faster than 5. Playing Mode is the mode to use when the animation reaches an end. The Repeat option will keep on repeating the animation, from beginning to end, as long as the PDF file is open. The swing option will keep on playing the animation, from beginning to end then from end to beginning, as long as the PDF file is open. The Play Once option will play the animation only once.

image.png

In WebGL exporter, the user can add a message box to the exported HTML by selecting Message Box from Action in Properties Panel for any objects in the scene. Write the message body and give it a title. Here in the message box tab, the user can select the style of the message box which will be displayed in the HTML file, there are four styles to select from.

image.png


image.png

With a template selected, click  Export from the menu or in the HTML 5 Settings dialog, then enter the name and location of the (*.html) file and click Save. The Export File dialog will open, where general final settings can be checked. If the Open file after the export checkbox is checked then the HTML file will open.

For 3D scenes with scene states defined, the Manage Scene States dialog will appear upon clicking Save. There the user can check the scene states to include in the exported HTML file, and their order.

image.png

Clouds

Share to SimLab Cloud

This function enables users to share their 3D scenes as VR Package on the SimLab cloud. When selecting this option the Login dialog will appear, where the user can Sign Up/Sign in.

image-1639759101774.png

Once the user logs in, the Cloud Sharing dialog will appear, allowing the user to share created 3D scenes with full features as VR Package. Full features mean all created animation, scene states, actions, and more. By default, a user will start with a trial sharing space of 2 GB valid for 3 months.

image-1639759135912.png

image-1639759144762.png

A user can manage uploaded files by clicking the Manage Cloud Files button in the Cloud Sharing dialog, which will open the Sharing Manager dialog. As the sharing period or space are expired, a user can purchase SimLab Sharing keys. To learn more about sharing methods and capabilities please refer to this video tutorial (Share VR Package section ONLY).